Invalid JDK version in profile 'java8-and-higher'

43
26 июня 2019, 04:00

Мавен при инстале дает такую ошибку:

Project ID: com.github.jai-imageio:jai-imageio-jpeg2000
Reason: Invalid JDK version in profile 'java8-and-higher': Unbounded 
range: [1.8, for project com.github.jai-imageio:jai-imageio-jpeg2000

В проекте стоит jdk 1.7.

pom:

<profile>
    <id>java8-and-higher</id>
    <activation>
        <jdk>[1.8,)</jdk>
    </activation>
</profile>

<dependency>
    <groupId>com.github.jai-imageio</groupId>
    <artifactId>jai-imageio-jpeg2000</artifactId>
    <version>1.3.0</version>
</dependency>
READ ALSO
Вернуть ответ в формате json

Вернуть ответ в формате json

У меня есть RestController который делает POST и GETМне нужно чтобы возращаемые данные у меня отображались как json

47
Как создать экземпляр TableView

Как создать экземпляр TableView

Я хочу создать приложение для аэропортов в JavaFXВот как создать это представление с помощью CSS

56